aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-17 00:30:21 +0100
committerMathias Kresin <dev@kresin.me>2017-12-21 01:05:16 +0100
commit6545c71d2c7c766e9caadd379192d39a94c949ad (patch)
treeacff36e30eb6557163769b4d58a6c85daf20e9f2 /target/linux/ramips/image/Makefile
parent7d3ec5f8332859be4c5da6275df1cbdfad6e73b5 (diff)
downloadupstream-6545c71d2c7c766e9caadd379192d39a94c949ad.tar.gz
upstream-6545c71d2c7c766e9caadd379192d39a94c949ad.tar.bz2
upstream-6545c71d2c7c766e9caadd379192d39a94c949ad.zip
ramips: sync image filename with boardname
Use <manufacturer>_<modelname> as image name for board using the devicetree compat string as boardname. Replace the underline of the device define, to keep the SUPPORTED_DEVICES in sync with a devicetree compat string based boardname. Override the default SUPPORTED_DEVICES for board which are having an userspace boardname with an underline. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c70761b250..ea7ce0bc90 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -39,7 +39,7 @@ define Device/Default
DEVICE_DTS_DIR := ../dts
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
- SUPPORTED_DEVICES = $(1)
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef