aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorDavide Fioravanti <pantanastyle@gmail.com>2019-05-20 05:15:24 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-05-31 10:30:03 +0200
commit62ce6d58f2ed280744ea6ef793c2342494b12ce7 (patch)
treec6e733e2d5da9d2cab4c3722b751be252458d6c4 /target/linux/ramips/image/Makefile
parentd95dff162ae110e82674cc1511ef851be231b232 (diff)
downloadupstream-62ce6d58f2ed280744ea6ef793c2342494b12ce7.tar.gz
upstream-62ce6d58f2ed280744ea6ef793c2342494b12ce7.tar.bz2
upstream-62ce6d58f2ed280744ea6ef793c2342494b12ce7.zip
ramips: unify JCG helper command definition
This patch makes the JCG helper command definition available for every rampis target Signed-off-by: Davide Fioravanti <pantanastyle@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 145dbf4ec5..0a32859bec 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -11,6 +11,7 @@ DEVICE_VARS += DTS IMAGE_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
DEVICE_VARS += SEAMA_SIGNATURE SEAMA_MTDBLOCK
DEVICE_VARS += SERCOMM_HWID SERCOMM_HWVER SERCOMM_SWVER
+DEVICE_VARS += JCG_MAXSIZE
loadaddr-y := 0x80000000
loadaddr-$(CONFIG_TARGET_ramips_rt288x) := 0x88000000
@@ -46,6 +47,11 @@ define Device/seama
SEAMA_SIGNATURE :=
endef
+define Build/jcg-header
+ $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) $(if $(JCG_MAXSIZE), -m $(JCG_MAXSIZE),) -u $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/patch-dtb
$(call Image/BuildDTB,../dts/$(DTS).dts,$@.dtb)
$(STAGING_DIR_HOST)/bin/patch-dtb $@ $@.dtb