aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAndrew Pikler <andrew.pikler@gmail.com>2020-10-05 17:13:38 +0300
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commit40437b18f41918d7bbbb7da986b8842bf82f9ff0 (patch)
tree424b8648d97a5be705bc7902e89b5534aa8916ee /target/linux/ramips/image/Makefile
parent8ec997d0063bbc1ac41d1025f4c94ae6337899fa (diff)
downloadupstream-40437b18f41918d7bbbb7da986b8842bf82f9ff0.tar.gz
upstream-40437b18f41918d7bbbb7da986b8842bf82f9ff0.tar.bz2
upstream-40437b18f41918d7bbbb7da986b8842bf82f9ff0.zip
firmware: add tool for signing d-link ru router factory firmware images
Some Russian d-link routers require that their firmware be signed with a salted md5 checksum followed by the bytes 0x00 0xc0 0xff 0xee. This tool signs factory images the OEM's firmware accepts them. Signed-off-by: Andrew Pikler <andrew.pikler@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 309ccbdf90..4274c24884 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -148,6 +148,11 @@ define Build/sercom-seal
$(1)
endef
+define Build/sign-dlink-ru
+ sign_dlink_ru $@ $1 $2
+ mv $@.new $@
+endef
+
define Build/trx
$(STAGING_DIR_HOST)/bin/trx $(1) \
-o $@ \