aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-03 23:22:22 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 17:36:29 +0200
commit402138d12dca1a24d2837145c8d31c9d35769b9d (patch)
treea56f97e94a11311fd6c81622ca2e92d05a0d2c8f /target/linux/ramips/image/Makefile
parent7dd3a234bed4175a7a03f6dd42a4d16d3a80af1e (diff)
downloadupstream-402138d12dca1a24d2837145c8d31c9d35769b9d.tar.gz
upstream-402138d12dca1a24d2837145c8d31c9d35769b9d.tar.bz2
upstream-402138d12dca1a24d2837145c8d31c9d35769b9d.zip
ramips: Derive DTS name from device name in Makefile
This will automatically derive the DTS name as in ath79 and thus makes specifying DTS for every device obsolete. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> --- This patch only introduces the mechanism and is then followed by commits with renames and Makefile adjustments per subtarget. Eventually, those can be all squashed into a single commit or left as they are to enhance overview.
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 07251aebba..181c825873 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -23,8 +23,9 @@ KERNEL_DTB = kernel-bin | append-dtb | lzma
define Device/Default
PROFILES = Default
KERNEL := $(KERNEL_DTB) | uImage lzma
+ MTK_SOC :=
DEVICE_DTS_DIR := ../dts
- DEVICE_DTS = $$(DTS)
+ DEVICE_DTS = $$(MTK_SOC)_$(1)
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))