aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 22:58:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 20:02:55 +0100
commit3f14f034fb5e191f4a537998379d8e922ec31e8a (patch)
tree2daa222bf570dcd278377f8fe4c8969a92d4ead0 /target/linux/ramips/image/Makefile
parent1444e31a7bf54b796f8ef88e77fee255b959c6bb (diff)
downloadupstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.gz
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.bz2
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.zip
treewide: omit IMAGE_SIZE argument from check-size
Now that check-size uses IMAGE_SIZE by default, we can skip the argument from image recipes to reduce redundancy. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index e34bf37210..7c1f7c6c0b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -29,7 +29,7 @@ define Device/Default
IMAGES := sysupgrade.bin
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
endef
define Device/seama
@@ -41,9 +41,9 @@ define Device/seama
# - 36 bytes of META data (4-bytes aligned)
IMAGE/default := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs
IMAGE/sysupgrade.bin := \
- $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ $$(IMAGE/default) | seama | pad-rootfs | append-metadata | check-size
IMAGE/factory.bin := \
- $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size $$$$(IMAGE_SIZE)
+ $$(IMAGE/default) | pad-rootfs -x 64 | seama | seama-seal | check-size
SEAMA_SIGNATURE :=
endef