aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:37 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:27 +0200
commit363197311b342a59b3c67e4bd2dfea3b3030b456 (patch)
tree011d1f66850ea187a3e74f3badec2d108e705234 /target/linux/ramips/image/Makefile
parent24ded1810b071ec7e7c8d134e5491d9649c13dac (diff)
downloadupstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.gz
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.tar.bz2
upstream-363197311b342a59b3c67e4bd2dfea3b3030b456.zip
ramips: remove default IMAGE_SIZE for ramips target
Currently, ramips target defines 0x7b0000 as default IMAGE_SIZE for all devices in ramips target, i.e. this will be set if a device does not specify IMAGE_SIZE itself. From 92 devices using that default due to a "missing" IMAGE_SIZE, 14 were incorrect by a small amount (i.e. still "8M" flash) and 12 were completely off ("16M", "4M", ...). This patch thus removes the _default_ IMAGE_SIZE and defines IMAGE_SIZE for each device individually. This should indicate to people supporting new devices that this parameter has to be cared about. For the present code, this patch is cosmetical. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index b58d4a9ec2..1eaf65c254 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -27,7 +27,6 @@ define Device/Default
DEVICE_DTS_DIR := ../dts
DEVICE_DTS = $$(MTK_SOC)_$(1)
IMAGES := sysupgrade.bin
- IMAGE_SIZE := $(ralink_default_fw_size_8M)
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)