aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-12 18:04:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-12 18:04:47 +0000
commit22ec8b4839f3a4cffdce1d476f1911dc8463f495 (patch)
tree8fc11bdeb316f63ef52ec11624fa64acdd607fc9 /target/linux/ramips/image/Makefile
parentb7f129e19be1950ad019b029aec377ec063663fc (diff)
downloadupstream-22ec8b4839f3a4cffdce1d476f1911dc8463f495.tar.gz
upstream-22ec8b4839f3a4cffdce1d476f1911dc8463f495.tar.bz2
upstream-22ec8b4839f3a4cffdce1d476f1911dc8463f495.zip
ramips: use GENERIC_{4,8}M image template for WR5123GN
SVN-Revision: 30483
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 0a1436ddfd..347bafdb76 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -308,12 +308,9 @@ define Image/Build/Template/F5D8235V1
$(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
endef
-
-mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
define Image/Build/Profile/WR5123GN
- $(call BuildFirmware/Generic,$(1),wr512-3gn-4M,board="WR512-3GN",mtdlayout_wr5123gn,851968,3014656)
- $(call BuildFirmware/Generic,$(1),wr512-3gn-8M,board="WR512-3GN",mtdlayout_wr5123gn8m,851968,7208960)
+ $(call Image/Build/Template/GENERIC_4M,$(1),wr512-3gn-4M,WR512-3GN)
+ $(call Image/Build/Template/GENERIC_8M,$(1),wr512-3gn-8M,WR512-3GN)
endef
ifeq ($(CONFIG_RALINK_RT305X),y)