aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-04-19 19:36:55 +0200
committerPetr Štetiar <ynezz@true.cz>2019-03-24 01:44:24 +0100
commit1f149fcad38677cc917d249e32b4b791cde95702 (patch)
tree4d082a6e2b1612cf1fda307ad86bca81dce1f060 /target/linux/ramips/image/Makefile
parent5f40b519f3b211f440a8f96dc1ce9a1be60aa0c9 (diff)
downloadupstream-1f149fcad38677cc917d249e32b4b791cde95702.tar.gz
upstream-1f149fcad38677cc917d249e32b4b791cde95702.tar.bz2
upstream-1f149fcad38677cc917d249e32b4b791cde95702.zip
firmware-utils: mkdlinkfw: add kernel image offset
Some boards with JBOOT have partiton between bootloader and kernel image. This patch add possibility to change kernel partition start address. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 33c4f3132f..6eef596caf 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -114,6 +114,7 @@ define Build/mkdlinkfw
-k $(IMAGE_KERNEL) \
-r $(IMAGE_ROOTFS) \
-o $@ \
+ $(if $(DLINK_IMAGE_OFFSET), -O $(DLINK_IMAGE_OFFSET)) \
-s $(DLINK_FIRMWARE_SIZE)
endef
@@ -122,6 +123,7 @@ define Build/mkdlinkfw-factory
-m $(DLINK_ROM_ID) -f $(DLINK_FAMILY_MEMBER) \
-F $@ \
-o $@.new \
+ $(if $(DLINK_IMAGE_OFFSET), -O $(DLINK_IMAGE_OFFSET)) \
-s $(DLINK_FIRMWARE_SIZE)
mv $@.new $@
endef