aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-18 13:40:31 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-18 13:40:31 +0800
commit1e5d014ba237cf47092c41cf3657ec64d3b99b41 (patch)
treed121045d47f87e31b694774460881ccec4c94080 /target/linux/ramips/image/Makefile
parent51c6b14092761588a87d24330a3e37700e4be1b7 (diff)
downloadupstream-1e5d014ba237cf47092c41cf3657ec64d3b99b41.tar.gz
upstream-1e5d014ba237cf47092c41cf3657ec64d3b99b41.tar.bz2
upstream-1e5d014ba237cf47092c41cf3657ec64d3b99b41.zip
ramips: don't reuse KERNEL_DTB for lzma-loader
mt7621 overrides KERNEL_DTB to limit dictionary size, which isn't needed for our lzma loader. This saves 15KB on mt7621 devices using uimage-lzma-loader. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index a966ba4349..f93ea8ab2a 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -39,7 +39,7 @@ endef
define Device/uimage-lzma-loader
LOADER_TYPE := bin
- KERNEL := $(KERNEL_DTB) | loader-kernel | uImage none
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | uImage none
endef
define Device/seama