aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-12 20:26:06 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 19:43:30 +0100
commit0bf4d681d4f2e4bd3c3a61e7fe5dca2a40b1902f (patch)
tree857aaed26e9333e68f34e2c25dfc215a16289bc3 /target/linux/ramips/image/Makefile
parenta972b1fb5f5d5c159b0310b3623cfd5442a5c322 (diff)
downloadupstream-0bf4d681d4f2e4bd3c3a61e7fe5dca2a40b1902f.tar.gz
upstream-0bf4d681d4f2e4bd3c3a61e7fe5dca2a40b1902f.tar.bz2
upstream-0bf4d681d4f2e4bd3c3a61e7fe5dca2a40b1902f.zip
ramips: allow JCG_MAXSIZE in kiB in Build/jcg-header
This allows JCG_MAXSIZE to be specified in kilobytes. This makes this value more consistent and easier comparable with other size variables. This also changes the only occurence of the variable, for Cudy WR1000. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d700e69440..4f65583f13 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -48,7 +48,9 @@ define Device/seama
endef
define Build/jcg-header
- $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) $(if $(JCG_MAXSIZE), -m $(JCG_MAXSIZE),) -u $@ -o $@.new
+ $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
+ $(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \
+ -u $@ -o $@.new
mv $@.new $@
endef