aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-06-19 10:06:50 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-03 11:18:39 +0200
commit09b6755946409d8fd8e95fab003f037ae026f04b (patch)
treedfd1423079f57d5290fa82f2c84bc329950cdcfe /target/linux/ramips/image/Makefile
parentb54bef205846e2b30da23c1316c4a9b941c5078d (diff)
downloadupstream-09b6755946409d8fd8e95fab003f037ae026f04b.tar.gz
upstream-09b6755946409d8fd8e95fab003f037ae026f04b.tar.bz2
upstream-09b6755946409d8fd8e95fab003f037ae026f04b.zip
ramips: limit dictionary size for lzma compression
In some cases, recent builds fail to boot from flash with at least some MT7621 based devices. The error message is: "LZMA ERROR 1 - must RESET board to recover" Booting the same kernel via TFTP works for some reason. Through testing I figured out that limiting the LZMA dictionary size seems to prevent these errors Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 8ab8aa3a6c..cd77ffe411 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
KERNEL_LOADADDR := $(loadaddr-y)
-KERNEL_DTB = kernel-bin | patch-dtb | lzma
+KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
define Device/Default
PROFILES = Default $$(DTS)
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)