aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-11-12 01:23:07 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-05-17 18:41:48 +0200
commita4e9c8f14b63cd44300ed452312c03a69aae9ca1 (patch)
tree0b3a77ff42a5e42b489913ac9e0e461a4d12c119 /target/linux/ramips/image/Makefile
parent46674723e1a44785b7638a7a1069139312c08bc2 (diff)
downloadupstream-a4e9c8f14b63cd44300ed452312c03a69aae9ca1.tar.gz
upstream-a4e9c8f14b63cd44300ed452312c03a69aae9ca1.tar.bz2
upstream-a4e9c8f14b63cd44300ed452312c03a69aae9ca1.zip
ramips: add support for netis WF2770
netis WF2770 is a 2.4/5GHz band AC750 router, based on MediaTek MT7620A. Specifications: - SoC: MT7620A - RAM: DDR2 64MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7610EN - Ethernet: 5x 10/100/1000Mbps - Switch: MT7530BU - UART: - J2: 3.3V, RX, TX, GND (3.3V is the square pad) / 57600 8N1 MAC addresses in factory partition: 0x0004: LAN, WiFi 2.4GHz (label_mac-6) 0x0028: not used (label_mac-1) 0x002e: WAN (label_mac) 0x8004: WiFi 5GHz (label_mac+2) Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Reviewed-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 4806226fd0..b00e6d8726 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -100,6 +100,12 @@ define Build/mkdlinkfw-factory
mv $@.new $@
endef
+define Build/netis-tail
+ echo -n $(1) >> $@
+ echo -n $(UIMAGE_NAME)-yun | $(STAGING_DIR_HOST)/bin/mkhash md5 | \
+ sed 's/../\\\\x&/g' | xargs echo -ne >> $@
+endef
+
define Build/poray-header
$(STAGING_DIR_HOST)/bin/mkporayfw $(1) -f $@ -o $@.new
mv $@.new $@