aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-04 16:09:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-04 16:09:13 +0000
commit0e486d2fd297d28ddfc34d4adb4eae7050f0d138 (patch)
tree5cc9baa2d7bb54a368db6f1389e9d1526ccac4d8 /target/linux/ramips/files
parent44c8b396f990bb1e762e1f9cef9bca34b78dc9f7 (diff)
downloadupstream-0e486d2fd297d28ddfc34d4adb4eae7050f0d138.tar.gz
upstream-0e486d2fd297d28ddfc34d4adb4eae7050f0d138.tar.bz2
upstream-0e486d2fd297d28ddfc34d4adb4eae7050f0d138.zip
ramips: add support for unbranded XDX-RN502J board
This patch adds support for routers using a PCB marked XDX-RN502J V2.0, such as some unbranded routers like this: http://www.mediafire.com/?8acv87h6snn9fj6 http://www.mediafire.com/?do7xonw7scor4kn http://www.mediafire.com/?1ad49zvx3e7jyix http://www.mediafire.com/?i46cqiq66maa197 http://www.aliexpress.com/product-fm/516397994-Free-Shipping-300M-3G-WAN-Wireless-N-WiFi-USB-AP-Router-2-Antennas-wholesalers.html some reports also state the Aceex 22Y uses the same board. more information can be found in the following openwrt forum post https://forum.openwrt.org/viewtopic.php?id=34878 [juhosg: fix checkpatch warnings, use the GENERIC_4M template] Signed-off-by: bruno schwander <bruno@tinkerbox.org> SVN-Revision: 30809
Diffstat (limited to 'target/linux/ramips/files')
-rw-r--r--target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig5
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-xdx-rn502j.c79
4 files changed, 86 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
index cfb6bc61aa..8234164424 100644
--- a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
+++ b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
@@ -49,6 +49,7 @@ enum ramips_mach_type {
RAMIPS_MACH_WL351, /* Sitecom WL-351 v1 002 */
RAMIPS_MACH_WR512_3GN, /* SH-WR512NU/WS-WR512N1-like 3GN*/
RAMIPS_MACH_WR6202, /* Accton WR6202 */
+ RAMIPS_MACH_XDXRN502J, /* unknown XDX-RN502J */
/* RT3662 based machines */
RAMIPS_MACH_RT_N56U, /* Asus RT-N56U */
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
index ae05190ec4..1bf960f7eb 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
@@ -121,6 +121,11 @@ config RT305X_MACH_NBG_419N
select RALINK_DEV_GPIO_BUTTONS
select RALINK_DEV_GPIO_LEDS
+config RT305X_MACH_XDX_RN502J
+ bool "Unknown board XDX-RN502J"
+ select RALINK_DEV_GPIO_BUTTONS
+ select RALINK_DEV_GPIO_LEDS
+
endmenu
endif
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index ce1d568237..aec57a0116 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -35,3 +35,4 @@ obj-$(CONFIG_RT305X_MACH_WR512_3GN) += mach-wr512-3gn.o
obj-$(CONFIG_RT305X_MACH_WL341V3) += mach-wl341v3.o
obj-$(CONFIG_RT305X_MACH_WL351) += mach-wl351.o
obj-$(CONFIG_RT305X_MACH_WR6202) += mach-wr6202.o
+obj-$(CONFIG_RT305X_MACH_XDX_RN502J) += mach-xdx-rn502j.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-xdx-rn502j.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-xdx-rn502j.c
new file mode 100644
index 0000000000..f7ef353262
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-xdx-rn502j.c
@@ -0,0 +1,79 @@
+/*
+ * Unknown router name/model, PCB marked with XDX-RN502J
+ *
+ * Copyright (C) 2011 Bruno Schwander bruno@tinkerbox.org
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define XDXRN502J_GPIO_BUTTON_RESET 12
+#define XDXRN502J_GPIO_LED_WIFI 7
+#define XDXRN502J_GPIO_LED_POWER 9
+
+#define XDXRN502J_BUTTONS_POLL_INTERVAL 20
+#define XDXRN502J_BUTTONS_DEBOUNCE_INTERVAL (3 * XDXRN502J_BUTTONS_POLL_INTERVAL)
+
+
+static struct gpio_led xdxrn502j_leds_gpio[] __initdata = {
+ {
+ .name = "xdxrn502j:green:wifi",
+ .gpio = XDXRN502J_GPIO_LED_WIFI,
+ .active_low = 1,
+ }, {
+ .name = "xdxrn502j:green:power",
+ .gpio = XDXRN502J_GPIO_LED_POWER,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button xdxrn502j_gpio_buttons[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = XDXRN502J_BUTTONS_DEBOUNCE_INTERVAL,
+ .gpio = XDXRN502J_GPIO_BUTTON_RESET,
+ .active_low = 1,
+ }
+};
+
+#define XDXRN502J_GPIO_MODE \
+ ((RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT) | \
+ RT305X_GPIO_MODE_MDIO)
+
+static void __init xdxrn502j_init(void)
+{
+ rt305x_gpio_init(XDXRN502J_GPIO_MODE);
+
+ rt305x_register_flash(0);
+
+ rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+ rt305x_register_ethernet();
+
+ ramips_register_gpio_leds(-1, ARRAY_SIZE(xdxrn502j_leds_gpio),
+ xdxrn502j_leds_gpio);
+
+ ramips_register_gpio_buttons(-1, XDXRN502J_BUTTONS_POLL_INTERVAL,
+ ARRAY_SIZE(xdxrn502j_gpio_buttons),
+ xdxrn502j_gpio_buttons);
+
+ rt305x_register_wifi();
+ rt305x_register_wdt();
+ rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_XDXRN502J, "XDXRN502J", "XDX RN502J",
+ xdxrn502j_init);