aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-02 19:17:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-02 19:17:59 +0000
commitb0449ccf04eae59aec6f90493d5a563fa8b15eea (patch)
tree86c8cf3400b022299c600f8d178c0275ecdaeff2 /target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
parent90e99b9fe893f829e5266ad53ece428ea2f56ccf (diff)
downloadupstream-b0449ccf04eae59aec6f90493d5a563fa8b15eea.tar.gz
upstream-b0449ccf04eae59aec6f90493d5a563fa8b15eea.tar.bz2
upstream-b0449ccf04eae59aec6f90493d5a563fa8b15eea.zip
ramips: W306R V2.0 - GPIO and Network fixes
Fixed: GPIO typos and confirmed GPIO_BUTTON_RESET Fixed: Lan & Wan reversed: swaped "eth0.2" with "eth0.1" by removing a line(default is correct), and reversed the Lan/wan layout LLLLW to WLLLL. Added: image/Makefile now builds -factory.bin files. I am unsure of the accepted way to change the makefile but the name of the image needs to be 'linkn Kernel Image' in order to be accepted by the OEM firmware. Known issue: eth0 (internal switch i think has mac address: 00:11:22:33:44:55 but i think it should be same as the lan). Known issue: Pressing the reset button has no noticable effect, i would expect the router to boot failsafe if being pressed on boot, reboot if short press and reset all to default if long press. [juhosg: remove mtdlayout_W306R and use mtdlayout_4M instead] Signed-off-by: David Pearce <david_18051985@hotmail.com> SVN-Revision: 31557
Diffstat (limited to 'target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c')
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
index 6235a7329d..7c8eb867cd 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
@@ -20,7 +20,7 @@
#include "devices.h"
-#define W306R_V20_GPIO_LED_SYS 9 /* FIXME */
+#define W306R_V20_GPIO_LED_SYS 9
#define W306R_V20_GPIO_LED_WPS 13
#define W306R_V20_GPIO_BUTTON_RESET 10
@@ -57,7 +57,7 @@ static void __init w306r_v20_init(void)
rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
- rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+ rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
rt305x_register_ethernet();
ramips_register_gpio_leds(-1, ARRAY_SIZE(w306r_v20_leds_gpio),
w306r_v20_leds_gpio);