aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-29 17:50:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-29 17:50:35 +0000
commitd6d06aceb0afee15594ed25a3ffd58fb7d5f4a19 (patch)
tree753e04aeaefd20a38b354483e3473c60db25bc6d /target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
parent76537041eb38380160e785bbea82096d9ed2fa1e (diff)
downloadupstream-d6d06aceb0afee15594ed25a3ffd58fb7d5f4a19.tar.gz
upstream-d6d06aceb0afee15594ed25a3ffd58fb7d5f4a19.tar.bz2
upstream-d6d06aceb0afee15594ed25a3ffd58fb7d5f4a19.zip
ramips: rt305x: add kernel support for the Planex MZK-W300NH2 Router
This is a Japanese market router, for details check http://www.planex.co.jp/product/router/mzk-w300nh2/. It has only 16MB RAM, but base OpenWRT install worked fine for days without issues. Even an image with built-in Luci worked, but don't expect smooth experience, due to the lack of RAM. Wifi was not extensively tested, but seems it is working. GPIO LEDs & buttons, factory flash image and switch config are confirmed working. Tested against revision 34882 + this patch. [juhosg: move user-space support and image generation changes into separate patches] Signed-off-by: Samir Ibradžić <sibradzic@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/3077/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34925
Diffstat (limited to 'target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile')
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index 321542df2e..8fa75352b1 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -49,4 +49,5 @@ obj-$(CONFIG_RT305X_MACH_WL_330N3G) += mach-wl-330n3g.o
obj-$(CONFIG_RT305X_MACH_WL341V3) += mach-wl341v3.o
obj-$(CONFIG_RT305X_MACH_WL351) += mach-wl351.o
obj-$(CONFIG_RT305X_MACH_WR6202) += mach-wr6202.o
+obj-$(CONFIG_RT305X_MACH_MZKW300NH2) += mach-mzk-w300nh2.o
obj-$(CONFIG_RT305X_MACH_XDX_RN502J) += mach-xdx-rn502j.o