aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-29 17:50:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-29 17:50:28 +0000
commit3fcb8bb0ddc282703f0b8027ee71a7ef2497c336 (patch)
tree81897eaede401068e89fa6f47e7cf76c1e4fcf1b /target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
parent87271e9f28796debd156da0b2466bc286ccbac0f (diff)
downloadupstream-3fcb8bb0ddc282703f0b8027ee71a7ef2497c336.tar.gz
upstream-3fcb8bb0ddc282703f0b8027ee71a7ef2497c336.tar.bz2
upstream-3fcb8bb0ddc282703f0b8027ee71a7ef2497c336.zip
ramips: rt305x: add kernel support for AirLive AIR3GII
AirLive AIR3GII is Ralink RT5350F based device with 100Mbps switch, USB port, 4MB flash and 32MB ram. Works: ethernet (LAN & WAN), wps button, led, USB, sysupgrade Does not work: wifi (chip RT5350), reset button [ 13.390000] phy0 -> rt2800_init_eeprom: Error - Invalid RT chipset 0x5350 detected. [ 13.400000] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device. Other problem: LAN leds is reverse (lights when not cable connected and vice versa) [juhosg: move user-space support and image generation changes into separate patches] Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/2913/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34922
Diffstat (limited to 'target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile')
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
index c61fba88cd..321542df2e 100644
--- a/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
+++ b/target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
@@ -14,6 +14,7 @@ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
obj-$(CONFIG_RT305X_MACH_3G_6200N) += mach-3g-6200n.o
obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B) += mach-argus-atp52b.o
obj-$(CONFIG_RT305X_MACH_BC2) += mach-bc2.o
+obj-$(CONFIG_RT305X_MACH_AIR3GII) += mach-air3gii.o
obj-$(CONFIG_RT305X_MACH_ALL0256N) += mach-all0256n.o
obj-$(CONFIG_RT305X_MACH_ALL5002) += mach-all5002.o
obj-$(CONFIG_RT305X_MACH_BROADWAY) += mach-broadway.o