aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-03 09:58:44 +0000
committerJohn Crispin <john@openwrt.org>2013-04-03 09:58:44 +0000
commitd4db00205d726f9faca3147cb345518ec5406aab (patch)
tree2e4466b8176c978c765dfeac1ea5f6ab5a0a203a /target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile
parent86a691144b4988d2ebfb78834b608dec51b53a33 (diff)
downloadupstream-d4db00205d726f9faca3147cb345518ec5406aab.tar.gz
upstream-d4db00205d726f9faca3147cb345518ec5406aab.tar.bz2
upstream-d4db00205d726f9faca3147cb345518ec5406aab.zip
move files to files-3.7
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36161
Diffstat (limited to 'target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile')
-rw-r--r--target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile b/target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile
new file mode 100644
index 0000000000..eb60c5d10d
--- /dev/null
+++ b/target/linux/ramips/files-3.7/arch/mips/ralink/rt288x/Makefile
@@ -0,0 +1,21 @@
+#
+# Makefile for the Ralink RT288x SoC specific parts of the kernel
+#
+# Copyright (C) 2010 Joonas Lahtinen <joonas.lahtinen@gmail.com>
+# Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+# Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License version 2 as published
+# by the Free Software Foundation.
+
+obj-y := irq.o setup.o rt288x.o devices.o clock.o
+
+obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+
+obj-$(CONFIG_RT288X_MACH_F5D8235_V1) += mach-f5d8235-v1.o
+obj-$(CONFIG_RT288X_MACH_BR6524N) += mach-br6524n.o
+obj-$(CONFIG_RT288X_MACH_RT_N15) += mach-rt-n15.o
+obj-$(CONFIG_RT288X_MACH_V11ST_FE) += mach-v11st-fe.o
+obj-$(CONFIG_RT288X_MACH_WLI_TX4_AG300N) += mach-wli-tx4-ag300n.o
+obj-$(CONFIG_RT288X_MACH_WZR_AGL300NH) += mach-wzr-agl300nh.o