aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-30 00:18:35 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-04 15:22:54 +0100
commit6ea5f7d44c8dccdf018af0aa9750903308aa95b7 (patch)
tree1b7c5343c49b51f1ac62fa93962bcf8f8fe5eb2c /target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts
parent09fe0c847dd32a829fd3dcb21e284cc0c7a3e763 (diff)
downloadupstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.gz
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.bz2
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.zip
ramips: fix MTK_SOC for RT3662 devices
rt3883.mk contains both RT3662 and RT3883 device profiles, but commit 6a104ac77206 set MTK_SOC to rt3883 for all devices. This patch fixes it, and renames dts files accordingly. And SoC compatible strings are also appended in the dts. Fixes: 6a104ac77206 ("ramips/rt288x,rt3883: Name DTS files based on scheme") Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts')
-rw-r--r--target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts68
1 files changed, 68 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts b/target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts
new file mode 100644
index 0000000000..af5ffda28e
--- /dev/null
+++ b/target/linux/ramips/dts/rt3662_loewe_wmdr-143n.dts
@@ -0,0 +1,68 @@
+/dts-v1/;
+
+#include "rt3883.dtsi"
+
+/ {
+ compatible = "loewe,wmdr-143n", "ralink,rt3662-soc", "ralink,rt3883-soc";
+ model = "Loewe WMDR-143N";
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x00010000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+};
+
+&ethernet {
+ port@0 {
+ phy-handle = <&phy0>;
+ phy-mode = "mii";
+ };
+ mdio-bus {
+ status = "okay";
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ phy-mode = "mii";
+ };
+ };
+};
+
+&wmac {
+ status = "okay";
+ ralink,mtd-eeprom = <&factory 0x0>;
+};