aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-30 00:18:35 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-04 15:22:54 +0100
commit6ea5f7d44c8dccdf018af0aa9750903308aa95b7 (patch)
tree1b7c5343c49b51f1ac62fa93962bcf8f8fe5eb2c /target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts
parent09fe0c847dd32a829fd3dcb21e284cc0c7a3e763 (diff)
downloadupstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.gz
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.bz2
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.zip
ramips: fix MTK_SOC for RT3662 devices
rt3883.mk contains both RT3662 and RT3883 device profiles, but commit 6a104ac77206 set MTK_SOC to rt3883 for all devices. This patch fixes it, and renames dts files accordingly. And SoC compatible strings are also appended in the dts. Fixes: 6a104ac77206 ("ramips/rt288x,rt3883: Name DTS files based on scheme") Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts')
-rw-r--r--target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts180
1 files changed, 180 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts b/target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts
new file mode 100644
index 0000000000..9e6d98f95a
--- /dev/null
+++ b/target/linux/ramips/dts/rt3662_edimax_br-6475nd.dts
@@ -0,0 +1,180 @@
+/dts-v1/;
+
+#include "rt3883.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "edimax,br-6475nd", "ralink,rt3662-soc", "ralink,rt3883-soc";
+ model = "Edimax BR-6475nD";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <100>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
+ linux,input-type = <EV_SW>;
+ linux,code = <KEY_RFKILL>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "br-6475nd:green:power";
+ gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan {
+ label = "br-6475nd:amber:wlan";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan_5ghz {
+ label = "br-6475nd:amber:wlan_5ghz";
+ gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ nor-flash@1c000000 {
+ compatible = "cfi-flash";
+ reg = <0x1c000000 0x800000>;
+ bank-width = <2>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ reg = <0x00000000 0x00030000>;
+ label = "u-boot";
+ read-only;
+ };
+
+ partition@30000 {
+ reg = <0x00030000 0x00010000>;
+ label = "nvram";
+ read-only;
+ };
+
+ factory: partition@40000 {
+ reg = <0x00040000 0x00010000>;
+ label = "factory";
+ read-only;
+ };
+
+ devdata: partition@50000 {
+ reg = <0x00050000 0x00020000>;
+ label = "devdata";
+ read-only;
+ };
+
+ partition@70000 {
+ compatible = "edimax,uimage";
+ reg = <0x00070000 0x00790000>;
+ label = "firmware";
+ };
+ };
+ };
+
+ rtl8367 {
+ compatible = "realtek,rtl8367";
+ gpio-sda = <&gpio0 5 GPIO_ACTIVE_HIGH>;
+ gpio-sck = <&gpio0 4 GPIO_ACTIVE_HIGH>;
+ realtek,extif0 = <1 0 1 1 1 1 1 1 2>;
+ };
+
+ /*
+ * Unclear if this is the correct gpio setup; the USB ports are
+ * unpopulated on a stock BR-6475nD, even though the hardware exists
+ * and the headers are there.
+ */
+ /*
+ gpio_export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ usb {
+ gpio-export,name="usb";
+ gpio-export,output=<0>;
+ gpios = <&gpio0 19 GPIO_ACTIVE_LOW>;
+ };
+ };
+ */
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "spi", "jtag", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&timer {
+ status = "okay";
+};
+
+&gpio1 {
+ status = "okay";
+};
+
+&uartlite {
+ status = "okay";
+};
+
+&ethernet {
+ status = "okay";
+ mtd-mac-address = <&devdata 0x0d>;
+
+ port@0 {
+ mediatek,fixed-link = <1000 1 1 1>;
+ };
+};
+
+&wmac {
+ status = "okay";
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pci {
+ status = "okay";
+};
+
+&pci1 {
+ status = "okay";
+
+ wifi@0,0 {
+ compatible = "pci0,0";
+ reg = <0x10000 0 0 0 0>;
+ ralink,5ghz = <0>;
+ ralink,mtd-eeprom = <&factory 0x8000>;
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};