aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/qoriq
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-04-26 18:18:20 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2022-06-14 12:03:55 +0300
commit86948716dbc1c220d4be504cfe5433bfd9e1d630 (patch)
tree1129705015e80fd2a36ff2c81c46cc8875a037a1 /target/linux/qoriq
parenta7be143646db9365f6ac8d5749a2dfef805789cb (diff)
downloadupstream-86948716dbc1c220d4be504cfe5433bfd9e1d630.tar.gz
upstream-86948716dbc1c220d4be504cfe5433bfd9e1d630.tar.bz2
upstream-86948716dbc1c220d4be504cfe5433bfd9e1d630.zip
qoriq: use KERNEL_SUFFIX in Build/sdcard-img
Use the KERNEL_SUFFIX variable in Build/sdcard-img, rather than using hardcoded "-kernel.bin", to allow overriding KERNEL_SUFFIX for a device. Fixes: 080a769b4da8 ("qoriq: new target") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/qoriq')
-rw-r--r--target/linux/qoriq/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/qoriq/image/Makefile b/target/linux/qoriq/image/Makefile
index a3c8dd38c2..ec46e4d543 100644
--- a/target/linux/qoriq/image/Makefile
+++ b/target/linux/qoriq/image/Makefile
@@ -8,7 +8,7 @@ SQUASHFSCOMP := xz $(LZMA_XZ_OPTIONS)
define Build/sdcard-img
rm -fR $@.boot
mkdir -p $@.boot
- $(CP) $(KDIR)/$(DEVICE_NAME)-kernel.bin $@.boot
+ $(CP) $(KDIR)/$(DEVICE_NAME)$(KERNEL_SUFFIX) $@.boot
$(if $(DEVICE_DTS),\
$(foreach dtb,$(DEVICE_DTS),$(CP) $(KDIR)/image-$(dtb).dtb $@.boot), \
$(CP) $(KDIR)/image-/*.dtb $@.boot)