aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/qoriq/image
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-08-07 02:41:11 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-12-21 21:37:46 +0200
commit3fda16078b9979be836df0d156ca0dc0a0778f91 (patch)
tree8a91413adcd9a24e16fbfc0cfadede97d38916d2 /target/linux/qoriq/image
parent080a769b4da8dfad8485d82ff94f5e844e561696 (diff)
downloadupstream-3fda16078b9979be836df0d156ca0dc0a0778f91.tar.gz
upstream-3fda16078b9979be836df0d156ca0dc0a0778f91.tar.bz2
upstream-3fda16078b9979be836df0d156ca0dc0a0778f91.zip
qoriq: add support for WatchGuard Firebox M300
This device is based on NXP's QorIQ T2081QDS board, with a quad-core dual-threaded 1.5 GHz ppc64 CPU and 4GB ECC RAM. The board has 5 ethernet interfaces, of which 3 are connected to the ethernet ports on the front panel. The other 2 are internally connected to a Marvell 88E6171 switch; the other 5 ports of this switch are also connected to the ethernet ports on the front panel. Installation: write the sdcard image to an SD card. Stock U-Boot will not boot, wait for it to fail then run these commands: setenv OpenWrt_fdt image-watchguard-firebox-m300.dtb setenv OpenWrt_kernel watchguard_firebox-m300-kernel.bin setenv wgBootSysA 'setenv bootargs root=/dev/mmcblk0p2 rw rootdelay=2 console=$consoledev,$baudrate fsl_dpaa_fman.fsl_fm_max_frm=1530; ext2load mmc 0:1 $fdtaddr $OpenWrt_fdt; ext2load mmc 0:1 $loadaddr $OpenWrt_kernel; bootm $loadaddr - $fdtaddr' saveenv reset The default U-Boot boot entry will now boot OpenWrt from the SD card. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'target/linux/qoriq/image')
-rw-r--r--target/linux/qoriq/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/qoriq/image/generic.mk b/target/linux/qoriq/image/generic.mk
index e69de29bb2..0d7f5e4c10 100644
--- a/target/linux/qoriq/image/generic.mk
+++ b/target/linux/qoriq/image/generic.mk
@@ -0,0 +1,12 @@
+define Device/watchguard_firebox-m300
+ DEVICE_VENDOR := WatchGuard
+ DEVICE_MODEL := Firebox M300
+ DEVICE_DTS_DIR := $(DTS_DIR)/fsl
+ DEVICE_PACKAGES := \
+ kmod-hwmon-w83793 kmod-ptp-qoriq kmod-rtc-rs5c372a kmod-tpm-i2c-atmel
+ KERNEL := kernel-bin | gzip | uImage gzip
+ IMAGES := sdcard.img.gz sysupgrade.img.gz
+ IMAGE/sysupgrade.img.gz := sdcard-img | gzip | append-metadata
+ IMAGE/sdcard.img.gz := sdcard-img | gzip
+endef
+TARGET_DEVICES += watchguard_firebox-m300