aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxcab
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
commit484051d05518b1f7fb53b535e84302849080272d (patch)
treed4fcbe83d1ea442b9b0a2470e95fc222536a114c /target/linux/pxcab
parent9ae19dcf8799314a89c7eabd57304c046f50d513 (diff)
downloadupstream-484051d05518b1f7fb53b535e84302849080272d.tar.gz
upstream-484051d05518b1f7fb53b535e84302849080272d.tar.bz2
upstream-484051d05518b1f7fb53b535e84302849080272d.zip
package/kernel: move target specific modules to their own target files
SVN-Revision: 21132
Diffstat (limited to 'target/linux/pxcab')
-rw-r--r--target/linux/pxcab/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/pxcab/modules.mk b/target/linux/pxcab/modules.mk
new file mode 100644
index 0000000000..742cbd2011
--- /dev/null
+++ b/target/linux/pxcab/modules.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/axonram
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=Axon DDR2 memory device driver
+ DEPENDS:=@TARGET_pxcab
+ KCONFIG:=CONFIG_AXON_RAM
+ FILES:=$(LINUX_DIR)/arch/powerpc/sysdev/axonram.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,01,axonram)
+endef
+
+define KernelPackage/axonram/description
+ Kernel support for Axon DDR2 memory device
+endef
+
+$(eval $(call KernelPackage,axonram))