aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-03 16:15:05 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-03 16:15:05 +0000
commit47c5c4df1c13f9118b81b6de55a9d695024e0fb9 (patch)
tree88412f5c4f1eb6fc2e47dbb1661fc95c23de969b /target/linux/pxa/profiles
parent89a9742bf7943fd733a35bed1995929cb9993452 (diff)
downloadupstream-47c5c4df1c13f9118b81b6de55a9d695024e0fb9.tar.gz
upstream-47c5c4df1c13f9118b81b6de55a9d695024e0fb9.tar.bz2
upstream-47c5c4df1c13f9118b81b6de55a9d695024e0fb9.zip
add Default and Gumstix PXA profiles
Gumstix builds a fake flash image for usage in qemu SVN-Revision: 33609
Diffstat (limited to 'target/linux/pxa/profiles')
-rw-r--r--target/linux/pxa/profiles/100-Default.mk17
-rw-r--r--target/linux/pxa/profiles/200-Gumstix.mk17
2 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/pxa/profiles/100-Default.mk b/target/linux/pxa/profiles/100-Default.mk
new file mode 100644
index 0000000000..566a43f7b9
--- /dev/null
+++ b/target/linux/pxa/profiles/100-Default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=
+endef
+
+define Profile/Default/Description
+ Default PXA Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/pxa/profiles/200-Gumstix.mk b/target/linux/pxa/profiles/200-Gumstix.mk
new file mode 100644
index 0000000000..f296414d4b
--- /dev/null
+++ b/target/linux/pxa/profiles/200-Gumstix.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Gumstix
+ NAME:=Gumstix
+ PACKAGES:=uboot-pxa-gumstix
+endef
+
+define Profile/Atheros-ath5k/Description
+ Package set compatible with the Gumstix boards
+endef
+$(eval $(call Profile,Gumstix))
+