aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ps3
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/ps3
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadupstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/ps3')
-rw-r--r--target/linux/ps3/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ps3/image/Makefile b/target/linux/ps3/image/Makefile
index 6a7773a340..9eb3d93f06 100644
--- a/target/linux/ps3/image/Makefile
+++ b/target/linux/ps3/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -14,8 +14,8 @@ endef
define Image/BuildKernel
mkdir -p $(BIN_DIR)
cp $(KDIR)/image $(BIN_DIR)/otheros.bld
- cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
- cp $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf $(TARGET_DIR)
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ cp $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf $(TARGET_DIR)
endef
$(eval $(call BuildImage))