aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ps3
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commit9d42bb1a218d092b8c9447cf16ec2c94f7881c8d (patch)
tree422842a370190fdfcc59b10055cbbf761974bb76 /target/linux/ps3
parentdebf59c4e6f85df3132eae86b2e8c8399040c1ce (diff)
downloadupstream-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.gz
upstream-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.bz2
upstream-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20834 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ps3')
-rw-r--r--target/linux/ps3/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ps3/image/Makefile b/target/linux/ps3/image/Makefile
index 6a7773a340..9eb3d93f06 100644
--- a/target/linux/ps3/image/Makefile
+++ b/target/linux/ps3/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -14,8 +14,8 @@ endef
define Image/BuildKernel
mkdir -p $(BIN_DIR)
cp $(KDIR)/image $(BIN_DIR)/otheros.bld
- cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
- cp $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf $(TARGET_DIR)
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ cp $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf $(TARGET_DIR)
endef
$(eval $(call BuildImage))