aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/modules.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:16:59 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commit406a3826dcbb48b5ea42f2d9e96ff92721a6440a (patch)
treeb011553d768a38899ae8522ad2c7348320b3f551 /target/linux/ppc40x/modules.mk
parent65cdfbabde3dbbc924233f2b8f01a356e0c74e7e (diff)
downloadupstream-406a3826dcbb48b5ea42f2d9e96ff92721a6440a.tar.gz
upstream-406a3826dcbb48b5ea42f2d9e96ff92721a6440a.tar.bz2
upstream-406a3826dcbb48b5ea42f2d9e96ff92721a6440a.zip
ppc40x: Remove unmaintained target
This target only supports kernel 3.18, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/ppc40x/modules.mk')
-rw-r--r--target/linux/ppc40x/modules.mk41
1 files changed, 0 insertions, 41 deletions
diff --git a/target/linux/ppc40x/modules.mk b/target/linux/ppc40x/modules.mk
deleted file mode 100644
index 4db39fac76..0000000000
--- a/target/linux/ppc40x/modules.mk
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define KernelPackage/ata-magicbox-cf
- SUBMENU:=$(BLOCK_MENU)
- TITLE:=Magicbox v2/OpenRB Compact flash support
- DEPENDS:=@TARGET_ppc40x
- KCONFIG:=CONFIG_PATA_MAGICBOX_CF
- FILES:=$(LINUX_DIR)/drivers/ata/pata_magicbox_cf.ko
- AUTOLOAD:=$(call AutoLoad,41,pata_magicbox_cf,1)
- $(call AddDepends/ata)
-endef
-
-define KernelPackage/ata-magicbox-cf/description
- Support for Magicbox v2/OpenRB on-board CF slot.
-endef
-
-$(eval $(call KernelPackage,ata-magicbox-cf))
-
-
-define KernelPackage/usb-isp116x-hcd
- TITLE:=Support for the ISP116x USB Host Controller
- DEPENDS:=@TARGET_ppc40x
- KCONFIG:= \
- CONFIG_USB_ISP116X_HCD \
- CONFIG_USB_ISP116X_HCD_OF=y \
- CONFIG_USB_ISP116X_HCD_PLATFORM=n
- FILES:=$(LINUX_DIR)/drivers/usb/host/isp116x-hcd.ko
- AUTOLOAD:=$(call AutoLoad,50,isp116x-hcd)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-isp116x-hcd/description
- Kernel support for the ISP116X USB Host Controller
-endef
-
-$(eval $(call KernelPackage,usb-isp116x-hcd))