aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-29 00:58:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-29 00:58:46 +0000
commit2f2ae0205c3377c77e9b213e6e53565557539b2b (patch)
treef1cbed37b6d8938056e3ba64f1607e8b9aaf977a /target/linux/ppc40x/image
parent36984a4cb5c3de368a4af36ea9ab890e77fd4415 (diff)
downloadupstream-2f2ae0205c3377c77e9b213e6e53565557539b2b.tar.gz
upstream-2f2ae0205c3377c77e9b213e6e53565557539b2b.tar.bz2
upstream-2f2ae0205c3377c77e9b213e6e53565557539b2b.zip
add basic support for the AMCC PPC405EX Kilauea evaluation board
SVN-Revision: 10303
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
new file mode 100644
index 0000000000..ce3f136583
--- /dev/null
+++ b/target/linux/ppc40x/image/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=128k
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(KDIR)/uImage
+ dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/kilauea.dts > $(KDIR)/openwrt-kilauea.dtb
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-128k
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+ dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+ dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+endef
+
+$(eval $(call BuildImage))