aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pistachio
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-04 22:47:27 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 13:02:44 +0200
commit047361dee44cab2b2355f7b7859fd688f6483cbc (patch)
treec025ae837defcf9cd9afd3d11a1b2930ac5fe9f6 /target/linux/pistachio
parentd798617d4aded6b922764bd5fea8651e12206afe (diff)
downloadupstream-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.gz
upstream-047361dee44cab2b2355f7b7859fd688f6483cbc.tar.bz2
upstream-047361dee44cab2b2355f7b7859fd688f6483cbc.zip
treewide: cleanup kernel symbol references
We only use 5.15 kernel. So remove all those unnecessary symbols referencing 5.10 or 5.15 kernel. Can be found with: git grep -E 'LINUX_5_1(0|5)' Note that we remove the dependency from "sound-soc-chipdip-dac" instead of removing the complete kernel package. The 5.15 version bump forgot to delete the "@LINUX_5_10" dependency. The kernel package is still needed in 5.15 kernel. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/pistachio')
-rw-r--r--target/linux/pistachio/image/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/pistachio/image/Makefile b/target/linux/pistachio/image/Makefile
index 9c0e9da91f..64898b46e0 100644
--- a/target/linux/pistachio/image/Makefile
+++ b/target/linux/pistachio/image/Makefile
@@ -5,11 +5,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-ifdef CONFIG_LINUX_5_10
- KERNEL_LOADADDR := 0x80400000
-else
- KERNEL_LOADADDR := 0x80100000
-endif
+KERNEL_LOADADDR := 0x80100000
define Device/Default
PROFILES := Default