aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-07 13:11:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-11 01:44:13 +0200
commitbb39fea11aae2888e6a0129055de21995da92073 (patch)
tree5dcca668bad0414fc458db065424b4ecc456e20a /target/linux/oxnas
parent108df3eabbb4dd93ff3c616c9455d69daaa98b49 (diff)
downloadupstream-bb39fea11aae2888e6a0129055de21995da92073.tar.gz
upstream-bb39fea11aae2888e6a0129055de21995da92073.tar.bz2
upstream-bb39fea11aae2888e6a0129055de21995da92073.zip
treewide: simplify inclusion of subtarget image files
Many target use a repetitive if-include scheme for their subtarget image files, though their names are consistent with the subtarget names. This patch removes these redundant conditions and just uses the variable for the include where the target setup allows it. For sunxi, this includes a trivial rename of the subtarget image Makefiles. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/image/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index 644c2b8795..abf83caa1a 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -4,12 +4,6 @@ include $(INCLUDE_DIR)/image.mk
VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux
UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
-ifeq ($(SUBTARGET),ox810se)
-include ox810se.mk
-endif
-
-ifeq ($(SUBTARGET),ox820)
-include ox820.mk
-endif
+include $(SUBTARGET).mk
$(eval $(call BuildImage))