aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 23:22:47 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 14:23:33 +0100
commit4159054fbbf8a7176eaf3dd4467c5b0db70769d0 (patch)
tree23742b8265e1613b76b76144ab1c91060abd2ae6 /target/linux/oxnas
parentdffbe668ab321c76c041aa15ca8b753deab2c4c5 (diff)
downloadupstream-4159054fbbf8a7176eaf3dd4467c5b0db70769d0.tar.gz
upstream-4159054fbbf8a7176eaf3dd4467c5b0db70769d0.tar.bz2
upstream-4159054fbbf8a7176eaf3dd4467c5b0db70769d0.zip
kernel: make kmod-hwmon-core selected by dependent modules
Currently kmod-hwmon-* will not get into images unless kmod-hwmon-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-hwmon-gpiofan - kmod-hwmon-lm63 - kmod-hwmon-lm75 - kmod-hwmon-lm85 - kmod-hwmon-lm90 Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx, adjust line wrapping] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/image/ox820.mk2
-rw-r--r--target/linux/oxnas/ox820/profiles/00-default.mk5
2 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/oxnas/image/ox820.mk b/target/linux/oxnas/image/ox820.mk
index 41ab3e230a..c0e0733f8e 100644
--- a/target/linux/oxnas/image/ox820.mk
+++ b/target/linux/oxnas/image/ox820.mk
@@ -71,7 +71,7 @@ define Device/shuttle_kd20
KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | encrypt-3des sohmuntitnlaes
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-usb-ledtrig-usbport \
kmod-usb3 kmod-i2c-gpio kmod-rtc-pcf8563 kmod-gpio-beeper \
- kmod-hwmon-core kmod-hwmon-gpiofan \
+ kmod-hwmon-gpiofan \
kmod-md-mod kmod-md-raid0 kmod-md-raid1 kmod-fs-ext4 kmod-fs-xfs
endef
TARGET_DEVICES += shuttle_kd20
diff --git a/target/linux/oxnas/ox820/profiles/00-default.mk b/target/linux/oxnas/ox820/profiles/00-default.mk
index fedf730088..c68d7cd9d6 100644
--- a/target/linux/oxnas/ox820/profiles/00-default.mk
+++ b/target/linux/oxnas/ox820/profiles/00-default.mk
@@ -9,9 +9,8 @@ define Profile/Default
NAME:=Default Profile
PRIORITY:=1
PACKAGES:=\
- kmod-i2c-gpio kmod-gpio-beeper kmod-hwmon-core \
- kmod-hwmon-gpiofan kmod-rtc-pcf8563 kmod-rtc-ds1307 \
- kmod-usb3
+ kmod-i2c-gpio kmod-gpio-beeper kmod-hwmon-gpiofan \
+ kmod-rtc-pcf8563 kmod-rtc-ds1307 kmod-usb3
endef
define Profile/Default/Description