aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/350-oxnas-reset.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
commit3256194aff475c16a0804690eff105a384e7307b (patch)
tree473fd150f89a1845fe22ad28c2890ddeb4d864bb /target/linux/oxnas/patches-4.0/350-oxnas-reset.patch
parent908a82ab61ae1c7b09bbe5c64d8d1001db208a24 (diff)
downloadupstream-3256194aff475c16a0804690eff105a384e7307b.tar.gz
upstream-3256194aff475c16a0804690eff105a384e7307b.tar.bz2
upstream-3256194aff475c16a0804690eff105a384e7307b.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
Diffstat (limited to 'target/linux/oxnas/patches-4.0/350-oxnas-reset.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/350-oxnas-reset.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/350-oxnas-reset.patch b/target/linux/oxnas/patches-4.0/350-oxnas-reset.patch
new file mode 100644
index 0000000000..0b0f0ae3c8
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/350-oxnas-reset.patch
@@ -0,0 +1,24 @@
+Index: linux-4.0-rc4/drivers/reset/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/reset/Kconfig
++++ linux-4.0-rc4/drivers/reset/Kconfig
+@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
+
+ If unsure, say no.
+
++config RESET_CONTROLLER_OXNAS
++ bool
++ select RESET_CONTROLLER
++
+ source "drivers/reset/sti/Kconfig"
++
+Index: linux-4.0-rc4/drivers/reset/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/reset/Makefile
++++ linux-4.0-rc4/drivers/reset/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
+ obj-$(CONFIG_ARCH_BERLIN) += reset-berlin.o
+ obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o