aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <john@openwrt.org>2014-11-26 09:00:08 +0000
commit72b58f2eb12ad4aa0c59481d0911dc5e39180eb5 (patch)
treebe51e2d36c4175443bd3ab42824df80c6b9a2efe /target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
parent40da7aae54ad7f098064f18e28eb8201afedfd5c (diff)
downloadupstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.tar.gz
upstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.tar.bz2
upstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
Diffstat (limited to 'target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch')
-rw-r--r--target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch b/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
new file mode 100644
index 0000000000..f2221dda88
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/800-oxnas-ehci.patch
@@ -0,0 +1,30 @@
+Index: linux-3.18-rc4/drivers/usb/host/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/usb/host/Kconfig
++++ linux-3.18-rc4/drivers/usb/host/Kconfig
+@@ -302,6 +302,13 @@ config USB_OCTEON_EHCI
+ USB 2.0 device support. All CN6XXX based chips with USB are
+ supported.
+
++config USB_EHCI_OXNAS
++ tristate "OXNAS EHCI Module"
++ depends on USB_EHCI_HCD && ARCH_OXNAS
++ select USB_EHCI_ROOT_HUB_TT
++ ---help---
++ Enable support for the OX820 SOC's on-chip EHCI controller.
++
+ endif # USB_EHCI_HCD
+
+ config USB_OXU210HP_HCD
+Index: linux-3.18-rc4/drivers/usb/host/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/usb/host/Makefile
++++ linux-3.18-rc4/drivers/usb/host/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
+ obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
+ obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
+ obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
++obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
+
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o