aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
commite553dfc356b7087e362f0daa283239ee01ae81f5 (patch)
treef91fac0c53ff97a1c3ceabce64fb9dd62933a3d2 /target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch
parentdcc8a8ca9eac90b3e70104c893464c27e62daed5 (diff)
downloadupstream-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.gz
upstream-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.bz2
upstream-e553dfc356b7087e362f0daa283239ee01ae81f5.zip
oxnas: re-add support for kernel 3.14
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
Diffstat (limited to 'target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch
new file mode 100644
index 0000000000..b6e2efb851
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/300-introduce-oxnas-platform.patch
@@ -0,0 +1,79 @@
+Index: linux-3.14.18/arch/arm/Kconfig
+===================================================================
+--- linux-3.14.18.orig/arch/arm/Kconfig
++++ linux-3.14.18/arch/arm/Kconfig
+@@ -367,6 +367,17 @@ config ARCH_VERSATILE
+ help
+ This enables support for ARM Ltd Versatile board.
+
++config ARCH_OXNAS
++ bool "Oxford Semiconductor 815/820/825 NAS SoC"
++ select ARCH_REQUIRE_GPIOLIB
++ select CLKDEV_LOOKUP
++ select GENERIC_CLOCKEVENTS
++ select COMMON_CLK
++ select MIGHT_HAVE_PCI
++ select ARCH_HAS_RESET_CONTROLLER
++ help
++ This enables support for Oxsemi 815/820/825 NAS SoC
++
+ config ARCH_AT91
+ bool "Atmel AT91"
+ select ARCH_REQUIRE_GPIOLIB
+@@ -999,6 +1010,8 @@ source "arch/arm/mach-omap2/Kconfig"
+
+ source "arch/arm/mach-orion5x/Kconfig"
+
++source "arch/arm/mach-oxnas/Kconfig"
++
+ source "arch/arm/mach-picoxcell/Kconfig"
+
+ source "arch/arm/mach-pxa/Kconfig"
+Index: linux-3.14.18/arch/arm/Makefile
+===================================================================
+--- linux-3.14.18.orig/arch/arm/Makefile
++++ linux-3.14.18/arch/arm/Makefile
+@@ -183,6 +183,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
+ machine-$(CONFIG_ARCH_OMAP1) += omap1
+ machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
+ machine-$(CONFIG_ARCH_ORION5X) += orion5x
++machine-$(CONFIG_ARCH_OXNAS) += oxnas
+ machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
+ machine-$(CONFIG_ARCH_PXA) += pxa
+ machine-$(CONFIG_ARCH_REALVIEW) += realview
+Index: linux-3.14.18/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-3.14.18.orig/arch/arm/boot/dts/Makefile
++++ linux-3.14.18/arch/arm/boot/dts/Makefile
+@@ -233,6 +233,7 @@ dtb-$(CONFIG_ARCH_OMAP2PLUS) += omap2420
+ am43x-epos-evm.dtb \
+ dra7-evm.dtb
+ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-lacie-ethernet-disk-mini-v2.dtb
++dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
+ dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
+ dtb-$(CONFIG_ARCH_U8500) += ste-snowball.dtb \
+ ste-hrefprev60-stuib.dtb \
+Index: linux-3.14.18/arch/arm/tools/mach-types
+===================================================================
+--- linux-3.14.18.orig/arch/arm/tools/mach-types
++++ linux-3.14.18/arch/arm/tools/mach-types
+@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
+ edb9307a MACH_EDB9307A EDB9307A 1128
+ omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
+ vstms MACH_VSTMS VSTMS 1140
++ox820 MACH_OX820 OX820 1152
+ micro9m MACH_MICRO9M MICRO9M 1169
+ bug MACH_BUG BUG 1179
+ at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
+Index: linux-3.14.18/drivers/clk/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/clk/Makefile
++++ linux-3.14.18/drivers/clk/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MACH_LOONGSON1) += clk-ls1
+ obj-$(CONFIG_COMMON_CLK_MAX77686) += clk-max77686.o
+ obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o
+ obj-$(CONFIG_ARCH_NSPIRE) += clk-nspire.o
++obj-$(CONFIG_ARCH_OXNAS) += clk-oxnas.o
+ obj-$(CONFIG_CLK_PPC_CORENET) += clk-ppc-corenet.o
+ obj-$(CONFIG_COMMON_CLK_S2MPS11) += clk-s2mps11.o
+ obj-$(CONFIG_COMMON_CLK_SI5351) += clk-si5351.o