aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/image
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-11-04 18:22:33 +0100
committerDaniel Golle <daniel@makrotopia.org>2018-11-11 16:49:07 +0100
commit4f40d4ca73a6da3c88804c46f8c7ab0096cdabf1 (patch)
tree615efbd4919d57617d0ef43be9145fb10658e0b8 /target/linux/oxnas/image
parentf2a6d39b95b279a50db834cfe6d7fc9396be1c21 (diff)
downloadupstream-4f40d4ca73a6da3c88804c46f8c7ab0096cdabf1.tar.gz
upstream-4f40d4ca73a6da3c88804c46f8c7ab0096cdabf1.tar.bz2
upstream-4f40d4ca73a6da3c88804c46f8c7ab0096cdabf1.zip
oxnas: squash-pick commits from master branch
4f017c871d oxnas: switch to generic board detect ef9b169df0 oxnas: remove stray kernel config symbols cf7896117b oxnas: enable image metadata by setting SUPPORTED_DEVICES 9bcc08958b oxnas: add console=ttyS0,115200 argument to bootargs b831eb5363 oxnas: kd20: correct memory size to 256MB 217fe505b6 oxnas: remove superseded sysupgrade image check Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/image')
-rw-r--r--target/linux/oxnas/image/ox820.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/oxnas/image/ox820.mk b/target/linux/oxnas/image/ox820.mk
index 9d41270a37..60f85d11da 100644
--- a/target/linux/oxnas/image/ox820.mk
+++ b/target/linux/oxnas/image/ox820.mk
@@ -39,6 +39,7 @@ endef
define Device/akitio-mycloud
DEVICE_DTS := ox820-akitio-mycloud
DEVICE_TITLE := Akition myCloud (mini) / SilverStone DC01
+ SUPPORTED_DEVICES := akitio,mycloud akitio
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-ledtrig-usbdev \
kmod-i2c-gpio kmod-rtc-ds1307
endef
@@ -47,6 +48,7 @@ TARGET_DEVICES += akitio-mycloud
define Device/cloudengines-pogoplug-pro
DEVICE_DTS := ox820-cloudengines-pogoplug-pro
DEVICE_TITLE := Cloud Engines PogoPlug Pro (with mPCIe)
+ SUPPORTED_DEVICES := cloudengines,pogoplugpro pogoplug-pro
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ledtrig-usbdev
endef
TARGET_DEVICES += cloudengines-pogoplug-pro
@@ -54,6 +56,7 @@ TARGET_DEVICES += cloudengines-pogoplug-pro
define Device/cloudengines-pogoplug-series-3
DEVICE_DTS := ox820-cloudengines-pogoplug-series-3
DEVICE_TITLE := Cloud Engines PogoPlug Series V3 (without mPCIe)
+ SUPPORTED_DEVICES := cloudengines,pogoplugv3 pogoplug-v3
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ledtrig-usbdev
endef
TARGET_DEVICES += cloudengines-pogoplug-series-3
@@ -61,6 +64,7 @@ TARGET_DEVICES += cloudengines-pogoplug-series-3
define Device/shuttle-kd20
DEVICE_DTS := ox820-shuttle-kd20
DEVICE_TITLE := Shuttle KD20
+ SUPPORTED_DEVICES := shuttle,kd20 kd20
KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
KERNEL_INITRAMFS_SUFFIX := .tar.gz
@@ -75,6 +79,7 @@ TARGET_DEVICES += shuttle-kd20
define Device/mitrastar-stg212
DEVICE_DTS := ox820-mitrastar-stg212
DEVICE_TITLE := MitraStar STG-212
+ SUPPORTED_DEVICES := mitrastar,stg-212 stg212
KERNEL := kernel-bin | append-dtb | uImage none
DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-ledtrig-usbdev
endef