aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-07-19 09:58:42 +0300
committerJohn Crispin <john@phrozen.org>2018-07-30 11:03:02 +0200
commitca529e60d2dde215b3199583bda0f37454e0b896 (patch)
treed221d3eb47a1ae7fbedb1605f981409ce6197b26 /target/linux/omap
parent6a095e858718e91a56dc69f21b5ecb76237e7c28 (diff)
downloadupstream-ca529e60d2dde215b3199583bda0f37454e0b896.tar.gz
upstream-ca529e60d2dde215b3199583bda0f37454e0b896.tar.bz2
upstream-ca529e60d2dde215b3199583bda0f37454e0b896.zip
omap: add support for f2fs/ext4 overlay creation
add kernel support and include the tools for creating an overlay partition (f2fs or ext4) Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'target/linux/omap')
-rw-r--r--target/linux/omap/Makefile2
-rw-r--r--target/linux/omap/config-4.145
-rw-r--r--target/linux/omap/config-4.95
3 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/omap/Makefile b/target/linux/omap/Makefile
index fc8e40dee2..f22841e019 100644
--- a/target/linux/omap/Makefile
+++ b/target/linux/omap/Makefile
@@ -26,4 +26,6 @@ endef
include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
$(eval $(call BuildTarget))
diff --git a/target/linux/omap/config-4.14 b/target/linux/omap/config-4.14
index 7c60947e30..a94e127a44 100644
--- a/target/linux/omap/config-4.14
+++ b/target/linux/omap/config-4.14
@@ -232,6 +232,11 @@ CONFIG_EXTCON=y
CONFIG_EXTCON_PALMAS=y
CONFIG_EXTCON_USB_GPIO=y
CONFIG_FANOTIFY=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
CONFIG_FAT_FS=y
CONFIG_FB_CMDLINE=y
CONFIG_FHANDLE=y
diff --git a/target/linux/omap/config-4.9 b/target/linux/omap/config-4.9
index 4272c2f90f..9cd4084308 100644
--- a/target/linux/omap/config-4.9
+++ b/target/linux/omap/config-4.9
@@ -229,6 +229,11 @@ CONFIG_EXTCON=y
CONFIG_EXTCON_PALMAS=y
CONFIG_EXTCON_USB_GPIO=y
CONFIG_FANOTIFY=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
CONFIG_FAT_FS=y
CONFIG_FB_CMDLINE=y
CONFIG_FHANDLE=y