aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-07-19 09:48:56 +0300
committerJohn Crispin <john@phrozen.org>2018-07-30 11:03:02 +0200
commit40f66f1431b1a6638f05b75952d7b5a94e385e8d (patch)
treeb5878179ab4bd39816e2a8806d438b3a0c194355 /target/linux/omap
parentf9af9be8abb72838011c206029ee9274ccd8738e (diff)
downloadupstream-40f66f1431b1a6638f05b75952d7b5a94e385e8d.tar.gz
upstream-40f66f1431b1a6638f05b75952d7b5a94e385e8d.tar.bz2
upstream-40f66f1431b1a6638f05b75952d7b5a94e385e8d.zip
omap: rename image for sysupgrade compatibility
for sysupgrade to work we need to change the image name based on dts target name Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'target/linux/omap')
-rw-r--r--target/linux/omap/image/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index 2f1e5b5ac0..c7271aba8f 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -38,34 +38,34 @@ define Device/Default
KERNEL := kernel-bin
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
- SUPPORTED_DEVICES = $$(DEVICE_DTS)
+ SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
endef
#uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-define Device/am335x-evm
+define Device/ti_am335x-evm
DEVICE_TITLE := TI AM335x EVM
DEVICE_DTS := am335x-evm
endef
-TARGET_DEVICES += am335x-evm
+TARGET_DEVICES += ti_am335x-evm
-define Device/am335x-boneblack
+define Device/ti_am335x-bone-black
DEVICE_TITLE := TI AM335x BeagleBone Black
DEVICE_DTS := am335x-boneblack
endef
-TARGET_DEVICES += am335x-boneblack
+TARGET_DEVICES += ti_am335x-bone-black
-define Device/omap4-panda
+define Device/ti_omap4-panda
DEVICE_TITLE := OMAP4 TI pandaboard
DEVICE_DTS := omap4-panda
DEVICE_PACKAGES := kmod-usb-net-smsc95xx
endef
-TARGET_DEVICES += omap4-panda
+TARGET_DEVICES += ti_omap4-panda
-define Device/omap3-beagle
+define Device/ti_omap3-beagle
DEVICE_TITLE := OMAP3 TI beagleboard
DEVICE_DTS := omap3-beagle
# beagleboard doesn't have a network interface, support most common usb net
@@ -75,6 +75,6 @@ define Device/omap3-beagle
kmod-usb-net-smsc95xx kmod-usb-net-dm9601-ether
endef
-TARGET_DEVICES += omap3-beagle
+TARGET_DEVICES += ti_omap3-beagle
$(eval $(call BuildImage))