aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-18 14:14:01 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-21 11:57:22 +0200
commit05c74e4000ecdd205d24315984ac300a59c8fea0 (patch)
tree87d84bba012ce7af30b21cbf64f22aba160185ff /target/linux/omap
parenteff0a0e39e48e4d1d40fc2262f1394d6d391a8c0 (diff)
downloadupstream-05c74e4000ecdd205d24315984ac300a59c8fea0.tar.gz
upstream-05c74e4000ecdd205d24315984ac300a59c8fea0.tar.bz2
upstream-05c74e4000ecdd205d24315984ac300a59c8fea0.zip
omap: derive DEVICE_DTS from device name
In most cases the DEVICE_DTS name can be derived easily from the node name, so let's do this to enforce harmonized names where possible. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/omap')
-rw-r--r--target/linux/omap/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index 6a7b20199f..3700788804 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -35,6 +35,7 @@ define Device/Default
PROFILES := Default
KERNEL_NAME := zImage
KERNEL := kernel-bin
+ DEVICE_DTS = $(lastword $(subst _, ,$(1)))
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
@@ -45,7 +46,6 @@ endef
define Device/ti_am335x-evm
DEVICE_VENDOR := Texas Instruments
DEVICE_MODEL := AM335x EVM
- DEVICE_DTS := am335x-evm
endef
TARGET_DEVICES += ti_am335x-evm
@@ -61,7 +61,6 @@ TARGET_DEVICES += ti_am335x-bone-black
define Device/ti_omap4-panda
DEVICE_VENDOR := PandaBoard.org
DEVICE_MODEL := OMAP4 TI pandaboard
- DEVICE_DTS := omap4-panda
DEVICE_PACKAGES := kmod-usb-net-smsc95xx
endef
@@ -70,7 +69,6 @@ TARGET_DEVICES += ti_omap4-panda
define Device/ti_omap3-beagle
DEVICE_VENDOR := BeagleBoard.org
DEVICE_MODEL := OMAP3 TI beagleboard
- DEVICE_DTS := omap3-beagle
# beagleboard doesn't have a network interface, support most common usb net
DEVICE_PACKAGES := kmod-usb-net \
kmod-usb-net-asix kmod-usb-net-asix-ax88179 kmod-usb-net-hso \