aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap35xx/image
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2011-02-02 14:58:30 +0000
committerHamish Guthrie <hcg@openwrt.org>2011-02-02 14:58:30 +0000
commit1781e8ed26299d6f851c62a809f9ab856652cc72 (patch)
tree075b1467cdc6e2d61876a18eee287f58ee084771 /target/linux/omap35xx/image
parent023322c8a262443c11997b70ead98b2750e673f0 (diff)
downloadupstream-1781e8ed26299d6f851c62a809f9ab856652cc72.tar.gz
upstream-1781e8ed26299d6f851c62a809f9ab856652cc72.tar.bz2
upstream-1781e8ed26299d6f851c62a809f9ab856652cc72.zip
Add support for ubifs
SVN-Revision: 25310
Diffstat (limited to 'target/linux/omap35xx/image')
-rw-r--r--target/linux/omap35xx/image/Makefile7
-rw-r--r--target/linux/omap35xx/image/ubinize.cfg14
2 files changed, 20 insertions, 1 deletions
diff --git a/target/linux/omap35xx/image/Makefile b/target/linux/omap35xx/image/Makefile
index adaf395b70..e238c48af8 100644
--- a/target/linux/omap35xx/image/Makefile
+++ b/target/linux/omap35xx/image/Makefile
@@ -10,9 +10,12 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=128k
JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
+UBIFS_OPTS = -m 2048 -e 126KiB -c 1996
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+
define Image/BuildKernel
$(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux linux.bin
- mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image beagleboard" -d linux.bin uImage
+ mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image gumstix" -d linux.bin uImage
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'uImage.bin+mmc2' -d ../files/boot-mmc.cmd boot.scr
mv uImage $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-uImage
@@ -20,11 +23,13 @@ define Image/BuildKernel
rm linux.bin
endef
+ifndef CONFIG_TARGET_omap35xx_gumstix
define Image/Build
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1)
PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
$(call Image/Build/$(1),$(1))
endef
+endif
ifdef CONFIG_TARGET_omap35xx_gumstix
define Image/Prepare
diff --git a/target/linux/omap35xx/image/ubinize.cfg b/target/linux/omap35xx/image/ubinize.cfg
new file mode 100644
index 0000000000..49d55b9840
--- /dev/null
+++ b/target/linux/omap35xx/image/ubinize.cfg
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+