aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/olpc/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 23:08:11 +0000
commit62ccdcedae255174a46ef74d2e0a887f16ddb30f (patch)
treec61f885f5bdc75674f275920f157438d4bc748a7 /target/linux/olpc/image
parent2c3d7a423cabb394a9933ad18b317158130fbd74 (diff)
downloadupstream-62ccdcedae255174a46ef74d2e0a887f16ddb30f.tar.gz
upstream-62ccdcedae255174a46ef74d2e0a887f16ddb30f.tar.bz2
upstream-62ccdcedae255174a46ef74d2e0a887f16ddb30f.zip
make the image filenames a bit shorter
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9533 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/olpc/image')
-rw-r--r--target/linux/olpc/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/olpc/image/Makefile b/target/linux/olpc/image/Makefile
index 14050bb7f6..b6d95042aa 100644
--- a/target/linux/olpc/image/Makefile
+++ b/target/linux/olpc/image/Makefile
@@ -42,7 +42,7 @@ ifeq ($(CONFIG_OLPC_GRUB_IMAGES),y)
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
-e 's#@BAUDRATE@#$(CONFIG_OLPC_GRUB_BAUDRATE)#g' \
./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
- PADDING="$(CONFIG_OLPC_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_OLPC_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ PADDING="$(CONFIG_OLPC_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image $(CONFIG_OLPC_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
$(call Image/Build/grub/$(1))
endef
endif
@@ -68,14 +68,14 @@ define Image/Build/squashfs
endef
define Image/BuildKernel
- $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+ $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
endef
define Image/Build
$(call Image/Build/$(1))
$(call Image/Build/grub,$(1))
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
- $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
+ $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
endef
$(eval $(call BuildImage))