aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/olpc/Makefile
diff options
context:
space:
mode:
authorJens Muecke <jens@nons.de>2007-10-28 21:20:48 +0000
committerJens Muecke <jens@nons.de>2007-10-28 21:20:48 +0000
commitb314ffdd3abe3babc3ab9d4caea87e2d5da3d8ef (patch)
tree963fce7975bcbe4c1ca2c229ca78736aa8439c01 /target/linux/olpc/Makefile
parentdd6cef677b3b316a88a9550467c2379ffa9c9fdb (diff)
downloadupstream-b314ffdd3abe3babc3ab9d4caea87e2d5da3d8ef.tar.gz
upstream-b314ffdd3abe3babc3ab9d4caea87e2d5da3d8ef.tar.bz2
upstream-b314ffdd3abe3babc3ab9d4caea87e2d5da3d8ef.zip
Initial OLPC target
SVN-Revision: 9457
Diffstat (limited to 'target/linux/olpc/Makefile')
-rw-r--r--target/linux/olpc/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/olpc/Makefile b/target/linux/olpc/Makefile
new file mode 100644
index 0000000000..4ab3375373
--- /dev/null
+++ b/target/linux/olpc/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH=i386
+BOARD:=olpc
+BOARDNAME:=olpc
+FEATURES:=squashfs ext2
+
+LINUX_VERSION:=2.6.23
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+$(eval $(call Target,generic))
+$(eval $(call BuildTarget))
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+ Please install mkisofs. \
+))