aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2019-07-14 10:34:19 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-08-02 22:45:02 +0200
commitd07a263ae6cb0c34d36d092ecf08c54a05016047 (patch)
tree7e4369032076f140032e45c8c2b467d99c15c2d3 /target/linux/octeon
parent5e928acf22cdc956eabe6e4b2327b34eb0ee66da (diff)
downloadupstream-d07a263ae6cb0c34d36d092ecf08c54a05016047.tar.gz
upstream-d07a263ae6cb0c34d36d092ecf08c54a05016047.tar.bz2
upstream-d07a263ae6cb0c34d36d092ecf08c54a05016047.zip
octeon: split up DEVICE_TITLE
Splits up DEVICE_TITLE into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT. Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 299e9ba396..c14aa27a2b 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -30,15 +30,17 @@ TARGET_DEVICES += generic
ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
define Device/er
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := EdgeRouter
CMDLINE := $(ER_CMDLINE)
- DEVICE_TITLE := Ubiquiti EdgeRouter
endef
TARGET_DEVICES += er
ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
define Device/erlite
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := EdgeRouter Lite
CMDLINE := $(ERLITE_CMDLINE)
- DEVICE_TITLE := Ubiquiti EdgeRouter Lite
endef
TARGET_DEVICES += erlite