aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-26 14:11:18 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-28 21:55:22 +0100
commitcfd1a40583d66d5f6a30dec5bee0f7ebd4d252ef (patch)
tree5ff8dd356ccfa9f292f9fb9e613c37da24d9e6e4 /target/linux/octeon
parent5ad49ca0298677d660f85455ee2a27aab74fe49d (diff)
downloadupstream-cfd1a40583d66d5f6a30dec5bee0f7ebd4d252ef.tar.gz
upstream-cfd1a40583d66d5f6a30dec5bee0f7ebd4d252ef.tar.bz2
upstream-cfd1a40583d66d5f6a30dec5bee0f7ebd4d252ef.zip
octeon: re-enable CONFIG_CAVIUM_CN63XXP1 and EdgeRouter image
The symbol CONFIG_CAVIUM_CN63XXP1 was disabled during the bump to 4.19 (see Fixes:) with the following reason: No supported hardware uses CN63XXP1 and it causes "slight decrease in performance" However, it later turned out that the edgerouter image needed it, which led to having the device disabled in [1]. Still, dropping support of a device seems a harsh action for just removing a "slight" decrease in performance from the other devices. Thus, this enables CONFIG_CAVIUM_CN63XXP1 again, and essentially restores the situation present until (including) kernel 4.14 on this target. For OpenWrt as a platform, it seems more desirable to support all devices (and have them tested regularly via the snapshots) in this case. Users interested in maximum performance might still just remove the symbol again in their local build. [1] 3824fa26d256 ("octeon: disable edgerouter image") Fixes: 6c22545225cd ("target/octeon: Add Linux 4.19 support") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/config-5.42
-rw-r--r--target/linux/octeon/image/Makefile1
2 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/octeon/config-5.4 b/target/linux/octeon/config-5.4
index 30c84b08eb..b00f89b451 100644
--- a/target/linux/octeon/config-5.4
+++ b/target/linux/octeon/config-5.4
@@ -13,7 +13,7 @@ CONFIG_BLK_DEV_SD=y
CONFIG_BLK_MQ_PCI=y
CONFIG_BLK_SCSI_REQUEST=y
CONFIG_BUILTIN_DTB=y
-# CONFIG_CAVIUM_CN63XXP1 is not set
+CONFIG_CAVIUM_CN63XXP1=y
CONFIG_CAVIUM_OCTEON_CVMSEG_SIZE=0
CONFIG_CAVIUM_OCTEON_LOCK_L2=y
CONFIG_CAVIUM_OCTEON_LOCK_L2_EXCEPTION=y
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 8e97280479..11da22df3b 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -48,7 +48,6 @@ define Device/ubnt_edgerouter
DEVICE_MODEL := EdgeRouter
BOARD_NAME := er
CMDLINE := $(ER_CMDLINE)
- DEFAULT := n
endef
TARGET_DEVICES += ubnt_edgerouter