aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:18:49 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-26 23:00:26 +0100
commit1e3bfbafd37ccb32d0ed6618f4886e1dec6643d2 (patch)
tree3d529a2486dd2d7567e3abaadea039d0aa076f55 /target/linux/octeon
parent49d66e0468c14d8a05bd6c33056708d2051437cb (diff)
downloadupstream-1e3bfbafd37ccb32d0ed6618f4886e1dec6643d2.tar.gz
upstream-1e3bfbafd37ccb32d0ed6618f4886e1dec6643d2.tar.bz2
upstream-1e3bfbafd37ccb32d0ed6618f4886e1dec6643d2.zip
octeon: apply vendor_model scheme to device definition/image name
This updates the device definition name for octeon target to provide more useful names for the images and be consistent with the increasing number of targets following that scheme. Since the target is not using device tree yet, this does not touch board_name and thus sets BOARD_NAME in image Makefile to ensure sysupgrade is still working. While at it, move Build block before Device blocks and remove trailing whitespace for CMDLINE. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 42bd5df1da..e083e823c2 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -7,6 +7,11 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Build/strip-kernel
+ # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+ $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
+endef
+
define Device/Default
PROFILES = Default $$(DEVICE_NAME)
KERNEL_NAME := vmlinux.elf
@@ -17,11 +22,6 @@ define Device/Default
IMAGE/sysupgrade.tar := sysupgrade-tar
endef
-define Build/strip-kernel
- # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
- $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
-endef
-
define Device/generic
DEVICE_VENDOR := Generic
DEVICE_MODEL := Octeon
@@ -30,19 +30,21 @@ endef
TARGET_DEVICES += generic
ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
-define Device/er
+define Device/ubnt_edgerouter
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := EdgeRouter
- CMDLINE := $(ER_CMDLINE)
+ BOARD_NAME := er
+ CMDLINE := $(ER_CMDLINE)
endef
-TARGET_DEVICES += er
+TARGET_DEVICES += ubnt_edgerouter
ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
-define Device/erlite
+define Device/ubnt_edgerouter-lite
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := EdgeRouter Lite
- CMDLINE := $(ERLITE_CMDLINE)
+ BOARD_NAME := erlite
+ CMDLINE := $(ERLITE_CMDLINE)
endef
-TARGET_DEVICES += erlite
+TARGET_DEVICES += ubnt_edgerouter-lite
$(eval $(call BuildImage))