aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image
diff options
context:
space:
mode:
authorClemens Hopfer <openwrt@wireloss.net>2022-05-28 21:34:48 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-24 23:59:14 +0200
commit8c0930b70b4f8d7447e34a59d52b1a5485aa4d49 (patch)
tree6a8625b642e6a1d79752a8f540d346f35528ac78 /target/linux/octeon/image
parent29ed58c8bee1de5b1779494e88620862edc44700 (diff)
downloadupstream-8c0930b70b4f8d7447e34a59d52b1a5485aa4d49.tar.gz
upstream-8c0930b70b4f8d7447e34a59d52b1a5485aa4d49.tar.bz2
upstream-8c0930b70b4f8d7447e34a59d52b1a5485aa4d49.zip
octeon: add support for Ubiquiti UniFi Security Gateway
Ubiquiti UniFi Security Gateway (USG) is largely identical to the EdgeRouter Lite (ERLite-3) apart from a different board ID and two dome leds. Device data (from WikiDev): CPU: Cavium Octeon Plus CN5020 @500MHz 2-cores Ethernet: 3x Atheros AR8035-A GbE PHY's Flash: On-board 4MB Flash Storage: Internal 3.8GB USB Flash (Kingston ID) drive w/ 1.5GB free for use occupies single internal USB port. Serial: 1x RJ45 port on front panel. 115200, 8N1 Buttons: 1x Reset Flash instructions are identical to EdgeRouter Lite. Signed-off-by: Clemens Hopfer <openwrt@wireloss.net>
Diffstat (limited to 'target/linux/octeon/image')
-rw-r--r--target/linux/octeon/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 23adb884f8..fa845a2499 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -84,4 +84,14 @@ define Device/ubnt_edgerouter-lite
endef
TARGET_DEVICES += ubnt_edgerouter-lite
+define Device/ubnt_unifi-usg
+ $(Device/ubnt_edgerouter-lite)
+ DEVICE_MODEL := UniFi Security Gateway
+ BOARD_NAME := ubnt,usg
+ DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-leds-gpio
+ DEVICE_DTS := cn5020_ubnt_usg
+ KERNEL += | append-dtb-to-elf
+endef
+TARGET_DEVICES += ubnt_unifi-usg
+
$(eval $(call BuildImage))