aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/netlogic
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:48 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:48 +0000
commit8e776bf5aeb10583c85adace687a2beb9fa01add (patch)
tree5ff33d6d5c9dee7acc92ba96c2532b3ba99dc431 /target/linux/netlogic
parent7166fbbb676cc978a9174dee6744bfafdf0842e0 (diff)
downloadupstream-8e776bf5aeb10583c85adace687a2beb9fa01add.tar.gz
upstream-8e776bf5aeb10583c85adace687a2beb9fa01add.tar.bz2
upstream-8e776bf5aeb10583c85adace687a2beb9fa01add.zip
netlogic: fix modular USB build
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43039
Diffstat (limited to 'target/linux/netlogic')
-rw-r--r--target/linux/netlogic/patches-3.14/001-modular_usb.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/netlogic/patches-3.14/001-modular_usb.patch b/target/linux/netlogic/patches-3.14/001-modular_usb.patch
new file mode 100644
index 0000000000..c6c647393d
--- /dev/null
+++ b/target/linux/netlogic/patches-3.14/001-modular_usb.patch
@@ -0,0 +1,13 @@
+Index: linux-3.14.16/arch/mips/netlogic/xlp/Makefile
+===================================================================
+--- linux-3.14.16.orig/arch/mips/netlogic/xlp/Makefile 2014-08-07 16:50:59.000000000 -0700
++++ linux-3.14.16/arch/mips/netlogic/xlp/Makefile 2014-09-25 12:12:29.853539866 -0700
+@@ -1,4 +1,6 @@
+ obj-y += setup.o nlm_hal.o cop2-ex.o dt.o
+ obj-$(CONFIG_SMP) += wakeup.o
+-obj-$(CONFIG_USB) += usb-init.o
+-obj-$(CONFIG_USB) += usb-init-xlp2.o
++ifdef CONFIG_USB
++obj-y += usb-init.o
++obj-y += usb-init-xlp2.o
++endif