aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/netlogic/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:23 +0000
commitc6285fd82f1b631b77ad94be613dc4575cd9ed28 (patch)
treee3f509c9f2a585646d3e52f81e4fd0961bbb32ce /target/linux/netlogic/image/Makefile
parent2c62ad1fda41da36baaf3524440aa631c5fb81c6 (diff)
downloadupstream-c6285fd82f1b631b77ad94be613dc4575cd9ed28.tar.gz
upstream-c6285fd82f1b631b77ad94be613dc4575cd9ed28.tar.bz2
upstream-c6285fd82f1b631b77ad94be613dc4575cd9ed28.zip
netlogic: add XLR/XLP support
Add support for Broadcom/Netlogic XLR/XLP support Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43037
Diffstat (limited to 'target/linux/netlogic/image/Makefile')
-rw-r--r--target/linux/netlogic/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/netlogic/image/Makefile b/target/linux/netlogic/image/Makefile
new file mode 100644
index 0000000000..6dde9b0e59
--- /dev/null
+++ b/target/linux/netlogic/image/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))