aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 16:26:56 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commite0579aecf8de03dd7e529fa14193557014554699 (patch)
tree3f48590f077ade7ee86167f63ae15c1ea9ec6431 /target/linux/mxs
parent7f9d537f21f2bd79a8b5bfd86c50629c76b306dc (diff)
downloadupstream-e0579aecf8de03dd7e529fa14193557014554699.tar.gz
upstream-e0579aecf8de03dd7e529fa14193557014554699.tar.bz2
upstream-e0579aecf8de03dd7e529fa14193557014554699.zip
mxs: put u-boot images into image staging directory
Do not put the u-boot images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index f0f1f6acf3..7c332cd7c2 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -40,7 +40,7 @@ define Image/Build/SDCard-vfat-ext4
./gen_sdcard_vfat_ext4.sh \
$(BIN_DIR)/$(2) \
- $(KDIR)/$(4)-u-boot.sb \
+ $(STAGING_DIR_IMAGE)/$(4)-u-boot.sb \
$(KDIR)/boot.img \
$(KDIR)/root.$(1) \
$(CONFIG_TARGET_BOOTFS_PARTSIZE) \
@@ -51,7 +51,7 @@ endef
define Image/Build/SDCard-ext4-ext4
./gen_sdcard_ext4_ext4.sh \
$(BIN_DIR)/$(2) \
- $(KDIR)/$(4)-u-boot.sb \
+ $(STAGING_DIR_IMAGE)/$(4)-u-boot.sb \
$(KDIR)/root.$(1) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)
$(call Image/Gzip,$(BIN_DIR)/$(2))