aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-13 15:23:36 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 16:59:28 +0100
commit8935689a8eb1fe9622273a9ee97131d99f1842fe (patch)
tree076ab71b4be1ba8aadc079bbad75f9a72c3a8c12 /target/linux/mxs
parent515d012e6daf4f1b3513688b942516211dfd6178 (diff)
downloadupstream-8935689a8eb1fe9622273a9ee97131d99f1842fe.tar.gz
upstream-8935689a8eb1fe9622273a9ee97131d99f1842fe.tar.bz2
upstream-8935689a8eb1fe9622273a9ee97131d99f1842fe.zip
mxs: gzip ext4 images
Significantly reduces disk usage Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index efa4ded44a..1daa26e00e 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -45,6 +45,7 @@ define Image/Build/SDCard-vfat-ext4
$(KDIR)/root.$(1) \
$(CONFIG_TARGET_BOOTFS_PARTSIZE) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $(call Image/Gzip,$(BIN_DIR)/$(2))
endef
define Image/Build/SDCard-ext4-ext4
@@ -53,6 +54,7 @@ define Image/Build/SDCard-ext4-ext4
$(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
$(KDIR)/root.$(1) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $(call Image/Gzip,$(BIN_DIR)/$(2))
endef
define Image/Build/Profile/olinuxino-maxi
@@ -71,6 +73,7 @@ define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Profile/$(PROFILE),$(1),$(IMG_PREFIX)-$(PROFILE)-sdcard.img)
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+ $(call Image/Gzip,$(BIN_DIR)/$(IMG_PREFIX)-root.$(1))
endef
$(eval $(call BuildImage))