aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-25 07:31:01 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-25 07:48:43 +0100
commit07c9bde0da177754ac5bf0865610b308e080a238 (patch)
tree4d5ed1c3dd8e082a4c3ef3621dcc4e4c6c006359 /target/linux/mxs
parent1c0addb15608b7a0d73fd056524f505df02eb5e3 (diff)
downloadupstream-07c9bde0da177754ac5bf0865610b308e080a238.tar.gz
upstream-07c9bde0da177754ac5bf0865610b308e080a238.tar.bz2
upstream-07c9bde0da177754ac5bf0865610b308e080a238.zip
mxs: fix image build issues
stage u-boot images in KERNEL_BUILD_DIR for building images always select uboot-mxs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 1daa26e00e..f0f1f6acf3 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -40,7 +40,7 @@ define Image/Build/SDCard-vfat-ext4
./gen_sdcard_vfat_ext4.sh \
$(BIN_DIR)/$(2) \
- $(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
+ $(KDIR)/$(4)-u-boot.sb \
$(KDIR)/boot.img \
$(KDIR)/root.$(1) \
$(CONFIG_TARGET_BOOTFS_PARTSIZE) \
@@ -51,7 +51,7 @@ endef
define Image/Build/SDCard-ext4-ext4
./gen_sdcard_ext4_ext4.sh \
$(BIN_DIR)/$(2) \
- $(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
+ $(KDIR)/$(4)-u-boot.sb \
$(KDIR)/root.$(1) \
$(CONFIG_TARGET_ROOTFS_PARTSIZE)
$(call Image/Gzip,$(BIN_DIR)/$(2))