aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/profiles/01-duckbill.mk
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2014-05-03 14:56:25 +0000
committerZoltan Herpai <wigyori@uid0.hu>2014-05-03 14:56:25 +0000
commit0c2f0c6a3b2505e6d2c18254a440de7e9622a69c (patch)
tree4f0032a8b991bf2f74d8a889690e47341b882343 /target/linux/mxs/profiles/01-duckbill.mk
parent18a7636c9f55b9bdfbebb94ed51689cfe17eb118 (diff)
downloadupstream-0c2f0c6a3b2505e6d2c18254a440de7e9622a69c.tar.gz
upstream-0c2f0c6a3b2505e6d2c18254a440de7e9622a69c.tar.bz2
upstream-0c2f0c6a3b2505e6d2c18254a440de7e9622a69c.zip
mxs: rename files so that profiles are sorted alphabetically
While at it, make spelling at little bit more consistent, at least for my taste :-) Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 40679
Diffstat (limited to 'target/linux/mxs/profiles/01-duckbill.mk')
-rw-r--r--target/linux/mxs/profiles/01-duckbill.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/mxs/profiles/01-duckbill.mk b/target/linux/mxs/profiles/01-duckbill.mk
new file mode 100644
index 0000000000..3f75a7aa77
--- /dev/null
+++ b/target/linux/mxs/profiles/01-duckbill.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+ NAME:=I2SE Duckbill boards
+ DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+ FEATURES+=usbgadget
+ PACKAGES+= \
+ -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+ kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper
+endef
+
+define Profile/duckbill/Description
+ I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))